-オープンソースのSNSエンジン OpenPNEプロジェクト-

opOpenSocialPlugin 0.9.3 リリースのお知らせ

12 / 06 日曜日 2009

OpenPNE開発チームの川原です。
もはや12月です。

本日2009年12月6日(日)、opOpenSocialPlugin 0.9.3-betaをリリースしました。

0.9.2-betaからのおもな変更点

  • 【改善】管理画面文言等の修正
  • 【新機能】#260 Albums API, Mediaitems APIでの取得の対応(試験的)
  • 【バグ】#267アクセスブロックに対応していない問題の修正
  • OpenPNE3.3.xへの対応等

導入方法

OpenPNE3.1.3以上が必要です。
3.1.3未満のバージョンをご利用している場合は、OpenPNE本体を事前にバージョンアップを行ってください。
また、Albums APIを利用する際は、opAlbumPluginと一緒に利用してください。

あらかじめ過去のopOpenSocialPluginが導入されている場合、以下のようにします。
バージョンアップ前にデータベースのバックアップを行ってください。


$ ./symfony opPlugin:install -s beta -r 0.9.3 opOpenSocialPlugin
$ ./symfony cc

本番運用等で複数のガジェットアプリを提供する場合、セキュリティ上の理由からコンテナを別のドメイン上に設置する必要があります。
(今回のバージョンから、管理画面で、この件についての警告等を大きく出すようにしています。)
ドキュメントに従い、設定するようにしてください。

今後のリリース

前回、12/24にリリースをするといっていましたが、小刻みにリリースをし、
最終的に3.3.x、3.4.xに同梱するバージョンを 1.0.0(stable)とすることにしました。

自分の予定等で変更になることがあるかもしれませんが、予定はロードマップをご覧ください。

開発やバグ報告・要望について

バグや要望等は、こちらから、報告ができます。

また、このプラグインはGithub上でソースコードの管理を行っています。
http://github.com/kawahara/opOpenSocialPlugin

forkやpull requestはお気軽に!(むしろください!)

コメント:0

コメントフォーム
お名前やメールアドレスを記録しますか?

トラックバック:0

この記事のトラックバックURL
http://www.openpne.jp/archives/4016/trackback/

ページの先頭に戻る