-オープンソースのSNSエンジン OpenPNEプロジェクト-

opDiaryPlugn 1.1.0 (開発版) リリースのお知らせ

12 / 18 金曜日 2009

OpenPNE3 用の日記プラグイン opDiaryPlugin のバージョン 1.1.0 をリリースしました。

今回のリリースは、 opDiaryPlugin v0.9.3 をベースに OpenPNE 3.3.x に対応した開発版になります。 v0.9.3 の内部コードを書き直しただけで機能追加はありません。

v1.1.0 での変更点

v0.9.3 からの変更点

  • #315: YAML の表記を新バージョンに合わせて修正
  • #345: テストスクリプトを OpenPNE 3.3.x で実行出来るように修正
  • #346: checkCSRFProtection を BaseForm クラスを元に検証するよう修正
  • #366: sfForm::useFields() を利用してフォームフィールドを定義するように変更
  • #367: sfRequest の ArrayAccess インターフェースを利用してリクエスト変数を取得するように変更

詳しくは、Redmine の v1.1.0 バージョン情報のページ をご覧ください。

アップデート手順

opDiaryPlugin v1.1.0 は、OpenPNE 3.3.x 以降に対応しています。OpenPNE 3.2.x では使えませんのでご注意ください。

opPlugin:install タスクをバージョンを指定して実行することでアップデートすることができます。

アップデート後は cc でキャッシュをクリアしてください。


$ php symfony opPlugin:install -r 1.1.0 opDiaryPlugin
$ php symfony cc

現在インストールされているプラグインのバージョンは plugin:list タスクを実行することで確認することができます。


$ php symfony plugin:list | grep opDiaryPlugin
opDiaryPlugin 1.1.0-beta # plugins.openpne.jp (plugins.openpne.jp)

「opDiaryPlugin 1.1.0-beta」という表記が確認できればインストール完了です。

バージョン体系について

opDiaryPlugin v0.9.0 以降はOpenPNE本体と同様バージョン番号の2つ目の数字が偶数のものが安定版、奇数のものが開発版と位置づけています。

例:

  • 0.9.3: 開発版
  • 1.0.0: 安定版
  • 1.1.0: 開発版

今後 OpenPNE 3.2.x と OpenPNE 3.3.x 以降のバージョンで opDiaryPlugin もソースコードを別にして管理するために、opDiaryPlugin v1.1.0 として 3.3.x に対応した開発版をリリースしていく予定です。

バージョン 最新版 OpenPNE のバージョン 安定性
0.9.x 0.9.3 OpenPNE 3.2.x 開発版
1.0.x(予定) OpenPNE 3.2.x 安定版
1.1.x 1.1.0 OpenPNE 3.3.x ~ 開発版

コメント:0

コメントフォーム
お名前やメールアドレスを記録しますか?

トラックバック:0

この記事のトラックバックURL
http://www.openpne.jp/archives/4084/trackback/

ページの先頭に戻る