-オープンソースのSNSエンジン OpenPNEプロジェクト-

OpenPNE2.14.1 , OpenPNE2.12.14 リリースのお知らせ

08 / 15 土曜日 2009

OpenPNE開発チームのきわです。

本日2009/08/14(金)、安定版 OpenPNE2.14.1 , 旧安定版 OpenPNE2.12.14 をリリースしました!
Amazon Product Advertising API仕様変更ギリギリ、お待たせしました!

Amazon Product Advertising API 仕様変更 PHP4対応

7月にリリースしたAmazon Product Advertising API の仕様変更がPHP4 系の環境で動作しない問題について、今回のリリースで対応しました。PHP4 系の環境でOpenPNEをご利用のかたはバージョンアップをお願いします。

OpenPNE2.10 / OpenPNE2.8 への対応パッチは以下になります。

7月リリースのパッチを適用している

修正分のみのパッチになります。

OpenPNE2.10.13
OpenPNE_2_10_x_Amazon_ticket_4166_fix.patch
OpenPNE2.8.11
OpenPNE_2_8_x_Amazon_ticket_4166_fix.patch

7月リリースのパッチを適用していない

Amazon Product Advertising API 仕様変更の全ての変更が含まれるパッチになります。

OpenPNE2.10.13
OpenPNE_2_10_x_Amazon_ticket_3982_4166_fix.patch
OpenPNE2.8.11
OpenPNE_2_8_x_Amazon_ticket_3982_4166_fix.patch

Amazon Product Advertising API 仕様変更についての詳細はこちらをご覧下さい。

【重要】AmazonアソシエイトWebサービス仕様変更に対応しました
http://www.openpne.jp/archives/2647/
ver2.8, 2.10 用AmazonアソシエイトWebサービス仕様変更対応パッチ
http://www.openpne.jp/archives/2670/

2.14 アップグレード時の不具合に対応

2.12→2.14 のアップグレード時に生じる不具合に対応しました。

upgrade sql がMySQL4.0環境で実行できない問題

2.14 の update sql(update09), upgrade sqlがMySQL4.0環境で実行できない問題を修正しました。
実行方法など、詳細についてはこちらのエントリをご覧下さい。

2.12→2.14のアップグレードSQLがエラーで中断される問題
http://www.openpne.jp/archives/2710/

OPENPNE_PUBLIC_HTML_DIRを変更していた場合、upgrade scriptがエラーになる問題

config.phpにて「OPENPNE_PUBLIC_HTML_DIR」がpublic_html 以外のディレクトリ名に変更されていた場合、upgrade script を実行するとエラーが発生し、実行できない問題が今回で修正されました。
2.14のアップロード容量制限機能をご利用のかたは、update scriptの再実行をお願いします。

バージョンアップ・インストール

バージョンアップ

バージョンアップ方法については以下をご覧ください。
http://www.openpne.jp/docs/pne-versionup/#post-73

インストール

インストール方法は、同梱されているセットアップドキュメント(setupディレクトリ以下にあります)をご覧ください。

ダウンロード

ダウンロード
http://www.openpne.jp/pne-downloads
安定版改定履歴
http://trac.openpne.jp/wiki/ChangeLog

次回リリース

次回のOpenPNE2.14, OpenPNE2.12リリース予定は2009/09/17(木)になります。

コメント:3

woo-poo 09-08-15 (土) 20:03

ダウンロードページのリンク先は、ファイルリストが表示されるだけで2.14.1が見あたりませんが、2.14.0からパッチを当てていくしかないのでしょうか?1ファイルでの配布は無いのでしょうか?それともULし忘れか、リンク先の掲載に時間がかかるのでしょうか・・・。

gen 09-08-18 (火) 9:18

Index: webapp/version.php
===================================================================
— webapp/version.php (…/OpenPNE-2.14.0) (リビジョン 12654)
+++ webapp/version.php (…/OpenPNE-2.14.1) (リビジョン 12654)
@@ -1 +1 @@

+

となってしましたが、2.14.1ではないのですか?

gen 09-08-18 (火) 9:20

消えてしまいました(^^;
パッチを当てるとバージョン表示が2.15-devとなっていますが、2.14.1ではないのでしょうか?

コメントフォーム
お名前やメールアドレスを記録しますか?

トラックバック:0

この記事のトラックバックURL
http://www.openpne.jp/archives/3271/trackback/

ページの先頭に戻る