-オープンソースのSNSエンジン OpenPNEプロジェクト-

opBlogPlugin 1.0.1 リリースのお知らせ

03 / 09 火曜日 2010

OpenPNE 開発チームの長澤です。

OpenPNE3 用の外部ブログプラグイン opBlogPlugin のバージョン 1.0.1 をリリースしました。

今回のリリースで、1.0.0.1 時点で発見されていたバグの修正が行われています。

1.0.1での変更点

#176: IE7でblogのURL設定画面のレイアウトが不自然
#648: opBlogPlugin 1.0.0.1で画像が変
#770: フレンドが一定以上になるとフレンドのブログリストが正常に取得されない
#772: ブログタイトルが多重エスケープされてしまう
#828: マイホームとプロフィールページの文言がおかしい
#771: change deprecated helper function to the function of substitution (非推奨関数を代替の関数に変更する)

詳しくは、Redmine の v1.0.1 バージョン情報のページをご覧ください。

アップデート手順

バージョン 1.0.x をお使いの方

opPlugin:install タスクを実行することで最新バージョンへのアップデートをおこなうことができます。


$ php symfony opPlugin:install -r 1.0.1 opBlogPlugin
$ php symfony cc

以上でアップデート完了です。

バージョン 0.9.x をお使いの方

opBlogPlugin 1.0.0 リリースのお知らせ の記事の手順でアップデートを行う必要があります。
その際は 1.0.0 となっている箇所を、1.0.1 と置き換えて作業を行ってください。

バージョンの確認

以下のコマンドでプラグインのバージョンを確認することができます。

$ php symfony plugin:list

正常にアップデートされていれば以下のように表示されます。

opBlogPlugin 1.0.1-stable # plugins.openpne.jp (plugins.openpne.jp)

開発やバグ報告・要望について

バグや要望等は、こちらから、報告ができます。

ソースコードは Github で管理されています。
バグ修正などしていただいた場合、pull request していただければと思います。
http://github.com/nothan/opBlogPlugin

コメント:4

りょういち 10-03-09 (火) 14:33

コマンドを実行して、アップデートは出来たようですが、
(表示がopBlogPlugin 1.0.1-stable になった)
その後下記の表示が出てサイトを開けなくなってしまいました。

(現在、サーバが混み合っているか、メンテナンス中です。
ご迷惑をおかけいたしますが、しばらく時間を空けて再度アクセスしてください。)

私が何かやり方を間違えたのでしょうか??

管理画面からopBlogPluginを無効にしたら治りました。
幸いまだ、ブログを利用していなかったので良かったです。

もし同じような症状がでた人がいたら、
対処方法を教えて頂けると助かります。

nagasawa 10-03-09 (火) 14:53

申し訳ございません、1.0.0 以前のバージョンをご利用の場合上記のみの操作だけでは足りていませんでした。

1.0.0 以前のバージョンをお使いの場合は
http://www.openpne.jp/archives/4330/
の記事の 1.0.0 を 1.0.1 に置き換えてアップデートをお願いします。
上記記事でアップデートを行う前に、
一度 opBlogPlugin のアンインストールをお願いします。

アンインストールのコマンドは以下になります。

php symfony opPlugin:uninstall opBlogPlugin

1.0.0以上のバージョンをお使いの場合でしたら
以下のコマンドを実行していただけると直る可能性があります。

3.5.x の場合ですと

php symfony doctrine:build --model
php symfony cc

3.2.x/3.4.x をご利用の場合は以下のコマンドになります。

php symfony doctrine:build-model
php symfony cc

りょういち 10-03-09 (火) 15:17

>nagasawa様

上記の通りにおこない
上手くなおったようです。

有難う御座いました。

jin 10-04-22 (木) 7:54

PNE3.4.0で招待メールを削除するとログインできなくなる
http://redmine.openpne.jp/issues/642
http://redmine.openpne.jp/issues/569

この不具合は修正されていないということでよろしいでしょうか?

opBlogPluginの再インストールも試しました。

コメントフォーム
お名前やメールアドレスを記録しますか?

トラックバック:0

この記事のトラックバックURL
http://www.openpne.jp/archives/4642/trackback/

ページの先頭に戻る